Log in

Online payments: Update your browser!

13 Mar 2018 1:56 PM | Anonymous member (Administrator)

Browser compatibility changes for online payments

To comply with industry security standards (PCI DSS), we are disabling Versions 1.0-1.1 of the TLS encryption protocol.
Some older browser versions do not support TLS 1.2, so visitors to your Wild Apricot site may have to upgrade their browsers if they want to make payments on your site. For more information and a list of compatible browser versions, click here.

© 2017/2018 Austrian Neuroscience Association (ANA) / Österreichische Gesellschaft für Neurowissenschaften (ÖGN)